RepeatingReferenceSourceHasRepeatingReferenceSource Method |
Determines whether an element has any repeating reference sources that can be used when creating component repeaters.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static bool HasRepeatingReferenceSource(
Document document,
ElementId elementId
)
Public Shared Function HasRepeatingReferenceSource (
document As Document,
elementId As ElementId
) As Boolean
public:
static bool HasRepeatingReferenceSource(
Document^ document,
ElementId^ elementId
)
static member HasRepeatingReferenceSource :
document : Document *
elementId : ElementId -> bool
Parameters
- document Document
-
The document that contains the element.
- elementId ElementId
-
The id of the element.
Return Value
Boolean
True if the element has any repeating reference sources.
Exceptions
See Also