RepeatingReferenceSourceGetReference Method

Returns an individual repeating reference given by coordinates in the array, or if there is no reference at the coordinates (for example if there is a hole in a divided surface.)

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public Reference GetReference(
	RepeaterCoordinates coordinates
)

Parameters

coordinates  RepeaterCoordinates
The coordinates in the array of repeating references.

Return Value

Reference
The repeating reference.
Exceptions
ExceptionCondition
ArgumentException The coordinates are not valid for the repeating reference source. This could be because of a mismatched dimensionality or because the coordinates are outside the bounds of the repeating reference source.
ArgumentNullException A non-optional argument was null
InvalidOperationException The repeating reference source is no longer valid.
Remarks
The coordinates must be within the bounds of the repeating reference source.
See Also