AssetSet Class

Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBAPIObject
    Autodesk.Revit.DB.VisualAssetSet

Namespace: Autodesk.Revit.DB.Visual
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class AssetSet : APIObject, IEnumerable

The AssetSet type exposes the following members.

Constructors
 NameDescription
Public methodAssetSetInitializes a new instance of the AssetSet class
Top
Properties
 NameDescription
Public propertyIsEmpty 
Public propertyCode exampleIsReadOnlyIdentifies if the object is read-only or modifiable.
(Inherited from APIObject)
Public propertySize 
Top
Methods
 NameDescription
Public methodClear 
Public methodContains 
Public methodDisposeCauses the object to release immediately any resources it may be utilizing.
(Inherited from APIObject)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodErase 
Public methodForwardIterator 
Public methodGetEnumerator 
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodInsert 
Public methodReverseIterator 
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also