INavisworksExporter Interface

The interface used to implement a Navisworks exporter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public interface INavisworksExporter : IExternalServer

The INavisworksExporter type exposes the following members.

Methods
 NameDescription
Public methodExport The method that Revit will invoke to perform an export to Navisworks.
Public methodGetDescription Implement this method to return a description of the server.
(Inherited from IExternalServer)
Public methodGetName Implement this method to return the name of the server.
(Inherited from IExternalServer)
Public methodGetServerId Implement this method to return the id of the server.
(Inherited from IExternalServer)
Public methodGetServiceId Implement this method to return the id of the service.
(Inherited from IExternalServer)
Public methodGetVendorId Implement this method to return the id of the vendor of the server.
(Inherited from IExternalServer)
Public methodValidateExportOptions Determines if the inputs are valid, and returns an error message if not.
Top
Remarks
Implement this interface and register an instance of the derived class with the Navisworks external service.
See Also