INavisworksExporter Interface

The interface used to implement a Navisworks exporter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public interface INavisworksExporter : IExternalServer

The INavisworksExporter type exposes the following members.

Methods
 NameDescription
Public methodExport The method that Revit will invoke to perform an export to Navisworks.
Public methodValidateExportOptions Determines if the inputs are valid, and returns an error message if not.
Top
Remarks
Implement this interface and register an instance of the derived class with the Navisworks external service.
See Also