INavisworksExporterValidateExportOptions Method |
Determines if the inputs are valid, and returns an error message if not.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxbool ValidateExportOptions(
Document document,
string folder,
string name,
NavisworksExportOptions options,
out string exceptionMessage
)
Function ValidateExportOptions (
document As Document,
folder As String,
name As String,
options As NavisworksExportOptions,
<OutAttribute> ByRef exceptionMessage As String
) As Boolean
bool ValidateExportOptions(
Document^ document,
String^ folder,
String^ name,
NavisworksExportOptions^ options,
[OutAttribute] String^% exceptionMessage
)
abstract ValidateExportOptions :
document : Document *
folder : string *
name : string *
options : NavisworksExportOptions *
exceptionMessage : string byref -> bool
Parameters
- document Document
-
The document to export.
- folder String
-
The folder path.
- name String
-
The file name.
- options NavisworksExportOptions
-
The export options.
- exceptionMessage String
-
The message to show in the exception thrown. This is not an end-user visible message, it is a
developer message, and does not have to be localized. Ignored if the function returns true.
Return Value
Boolean
True if the options are valid, false otherwise.
See Also