IExternalServerGetName Method

Implement this method to return the name of the server.

Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
string GetName()

Return Value

String
Name of the server.
Remarks

Although a server is uniquely identified by its Id, the Name can identify it to the end user in UI when UI is appropriate for the corresponding external service.

Beside the requirement for the name to be a non-empty string, there are no other general restrictions imposed by the External Services Framework. However, the external service may have some specific rules in place for its servers.

See Also