DesignToFabricationConverter Class

This class represents the MEP design to fabrication part convert tool.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DB.FabricationDesignToFabricationConverter

Namespace: Autodesk.Revit.DB.Fabrication
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class DesignToFabricationConverter : IDisposable

The DesignToFabricationConverter type exposes the following members.

Constructors
 NameDescription
Public methodDesignToFabricationConverter Creates a new instance of the DesignToFabricationConverter class.
Top
Properties
 NameDescription
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 NameDescription
Public methodConvert Converts the set of MEP design elements into fabrication parts.
Public methodDisposeReleases all resources used by the DesignToFabricationConverter
Public methodGetConvertedFabricationParts Gets the set of element identifiers for newly created fabrication parts.
Public methodGetConvertedFabricationPartsWithInvalidConnections Gets the collection of converted fabrication parts with invalid connections.
Public methodGetDesignElementAndFabricationPartsWithDifferentOffsets Gets the collection of design elements that failed to convert and the associated set of fabrication parts with different offsets.
Public methodGetDesignElementAndFabricationPartsWithOpenConnectors Gets the collection of design elements that failed to convert and the associated set of fabrication parts with open connectors.
Public methodGetElementsWithOpenConnector Gets the set of fabrication part or MEP design element identifiers with open connectors, caused by fittings failing to convert.
Public methodGetPartialConvertFailureResults Gets the partial failure results.
Public methodSetMapForFamilySymbolToFabricationPartType Set a map for the conversion of in line family symbols to similar fabrication part types.
Top
Remarks
After a new instance of the class is created, call the Convert method to convert the MEP design elements into fabrication parts. Use the method SetMapForFamilySymbolToFabricationPartType to optionally convert family content to fabrication parts prior to calling Convert by providing a mapping of family symbols to fabrication parts types. If not set, then during conversion these families will remain and any connections to other converted elements will be maintained. After the convert method has been invoked, query the class to obtain more information about the conversion:
See Also