DesignToFabricationConverterSetMapForFamilySymbolToFabricationPartType Method |
Set a map for the conversion of in line family symbols to similar fabrication part types.
Namespace: Autodesk.Revit.DB.FabricationAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic DesignToFabricationMappingResult SetMapForFamilySymbolToFabricationPartType(
IDictionary<ElementId, ElementId> typeMappings
)
Public Function SetMapForFamilySymbolToFabricationPartType (
typeMappings As IDictionary(Of ElementId, ElementId)
) As DesignToFabricationMappingResult
public:
DesignToFabricationMappingResult SetMapForFamilySymbolToFabricationPartType(
IDictionary<ElementId^, ElementId^>^ typeMappings
)
member SetMapForFamilySymbolToFabricationPartType :
typeMappings : IDictionary<ElementId, ElementId> -> DesignToFabricationMappingResult
Parameters
- typeMappings IDictionaryElementId, ElementId
-
The map containing the family symbol element identifiers to the fabrication part type element identifiers to convert to.
Return Value
DesignToFabricationMappingResult
If the mapping is properly structured, DesignToFabricationMappingResult.Success is returned. Otherwise, consult the members of DesignToFabricationMappingResult to understand why this call failed.
Exceptions
See Also