DesignToFabricationConverterGetDesignElementAndFabricationPartsWithDifferentOffsets Method |
Gets the collection of design elements that failed to convert and the associated set of fabrication parts with different offsets.
Namespace: Autodesk.Revit.DB.FabricationAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic IDictionary<ElementId, ISet<ElementId>> GetDesignElementAndFabricationPartsWithDifferentOffsets()
Public Function GetDesignElementAndFabricationPartsWithDifferentOffsets As IDictionary(Of ElementId, ISet(Of ElementId))
public:
IDictionary<ElementId^, ISet<ElementId^>^>^ GetDesignElementAndFabricationPartsWithDifferentOffsets()
member GetDesignElementAndFabricationPartsWithDifferentOffsets : unit -> IDictionary<ElementId, ISet<ElementId>>
Return Value
IDictionaryElementId,
ISetElementId
A map of design element identifiers that were not converted and the associated set fabrication parts left with different offsets.
Remarks
This set of element identifiers is only available after the Convert method has been invoked, and returns DesignToFabricationConverterResult::Enum::PartialFailure.
See Also