ElementParameterFilter Class

A filter used to match elements by one or more parameter filter rules.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBElementFilter
    Autodesk.Revit.DBElementSlowFilter
      Autodesk.Revit.DBElementParameterFilter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ElementParameterFilter : ElementSlowFilter

The ElementParameterFilter type exposes the following members.

Constructors
 NameDescription
Public methodElementParameterFilter(FilterRule) Constructs a new instance of an ElementParameterFilter from a single rule.
Public methodElementParameterFilter(IListFilterRule) Constructs a new instance of an ElementParameterFilter from a set of rules.
Public methodElementParameterFilter(FilterRule, Boolean) Constructs a new instance of an ElementParameterFilter, with the option to match all elements not passing a given filter rule.
Public methodElementParameterFilter(IListFilterRule, Boolean) Constructs a new instance of an ElementParameterFilter, with the option to match all elements not passing the given filter rules.
Top
Properties
 NameDescription
Public propertyInverted True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted.
(Inherited from ElementFilter)
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from ElementFilter)
Top
Methods
 NameDescription
Public methodDispose
(Inherited from ElementFilter)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetRules Returns the set of rules contained in this filter.
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodPassesFilter(Element) Applies the filter to a given element.
(Inherited from ElementFilter)
Public methodPassesFilter(Document, ElementId) Applies the filter to a given element.
(Inherited from ElementFilter)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks
This filter is a slow filter. Slow filters require that the Element be obtained and expanded in memory first. Thus it is preferable to couple this filter with at least one ElementQuickFilter, which should minimize the number of Elements that are expanded.
Example
// Creates an ElementParameter filter to find rooms whose area is 
// greater than specified value
// Create filter by provider and evaluator 
// provider
ParameterValueProvider pvp = new ParameterValueProvider(new ElementId(BuiltInParameter.ROOM_AREA));
// evaluator
FilterNumericRuleEvaluator fnrv = new FilterNumericGreater();
// rule value    
double ruleValue = 100.0f; // filter room whose area is greater than 100 SF
// rule
FilterRule fRule = new FilterDoubleRule(pvp, fnrv, ruleValue, 1E-6);

// Create an ElementParameter filter
ElementParameterFilter filter = new ElementParameterFilter(fRule);

// Apply the filter to the elements in the active document
FilteredElementCollector collector = new FilteredElementCollector(document);
IList<Element> rooms = collector.WherePasses(filter).ToElements();


// Find rooms whose area is less than or equal to 100: 
// Use inverted filter to match elements
ElementParameterFilter lessOrEqualFilter = new ElementParameterFilter(fRule, true); 
collector = new FilteredElementCollector(document);
IList<Element> lessOrEqualFounds = collector.WherePasses(lessOrEqualFilter).ToElements();
See Also