ElementParameterFilter(IListFilterRule, Boolean) Constructor |
Constructs a new instance of an ElementParameterFilter, with the option to match all elements not passing the given filter rules.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ElementParameterFilter(
IList<FilterRule> filterRules,
bool inverted
)
Public Sub New (
filterRules As IList(Of FilterRule),
inverted As Boolean
)
public:
ElementParameterFilter(
IList<FilterRule^>^ filterRules,
bool inverted
)
new :
filterRules : IList<FilterRule> *
inverted : bool -> ElementParameterFilter
Parameters
- filterRules IListFilterRule
-
The rules applied to test if the element passes this filter.
- inverted Boolean
-
True if the filter should match all elements which do not pass the filter rules.
Exceptions
See Also