ElementParameterFilter(FilterRule, Boolean) Constructor |
Constructs a new instance of an ElementParameterFilter, with the option to match all elements not passing a given filter rule.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ElementParameterFilter(
FilterRule filterRule,
bool inverted
)
Public Sub New (
filterRule As FilterRule,
inverted As Boolean
)
public:
ElementParameterFilter(
FilterRule^ filterRule,
bool inverted
)
new :
filterRule : FilterRule *
inverted : bool -> ElementParameterFilter
Parameters
- filterRule FilterRule
-
The rule applied to test if the element passes this filter.
- inverted Boolean
-
True if the filter should match all elements which do not pass the filter rule.
Exceptions
See Also