PostDocEventArgs Class

The class is used as base class for arguments of any post-event that is associated to a particular Document.
Inheritance Hierarchy
SystemObject
  SystemEventArgs
    Autodesk.Revit.DB.EventsRevitEventArgs
      Autodesk.Revit.DB.EventsPostEventArgs
        Autodesk.Revit.DB.EventsPostDocEventArgs

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class PostDocEventArgs : PostEventArgs

The PostDocEventArgs type exposes the following members.

Properties
 NameDescription
Public propertyCancel Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it.
(Inherited from RevitEventArgs)
Public propertyCancellable Indicates whether an event may be cancelled by an event delegate.
(Inherited from RevitEventArgs)
Public propertyDocument The document associated with the event.
Public propertyStatus Indicates whether the action associated with this event succeeded, failed, or was cancelled (by an APIevent handler).
(Inherited from PostEventArgs)
Top
Methods
 NameDescription
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also