NavisworksExportOptions Class

Options which controls the Navisworks export.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBNavisworksExportOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class NavisworksExportOptions : IDisposable

The NavisworksExportOptions type exposes the following members.

Constructors
 NameDescription
Public methodNavisworksExportOptions Create an instance of Navisworks Export Options set with default values.
Top
Properties
 NameDescription
Public propertyConvertElementProperties True to convert element properties, false otherwise. Default value is false.
Public propertyConvertLights True to convert lights, false otherwise. Default value is false.
Public propertyConvertLinkedCADFormats True to convert linked CAD formats, false otherwise. Default value is true.
Public propertyCoordinates Options which specifies the coordinates of Navisworks Exporter. Default value is Shared.
Public propertyDivideFileIntoLevels True to divide file into levels, false otherwise. Default value is true.
Public propertyExportElementIds True to export Revit element ids, false to skip these values. Default value is true.
Public propertyExportLinks True to export Revit links found in the main model, false to skip links. Default value is false.
Public propertyExportParts True to export Revit part elements, false to export the original parent elements. Default value is false.
Public propertyExportRoomAsAttribute True to export data for each room converts into a single shared room attribute, false otherwise. Default value is true.
Public propertyExportRoomGeometry True to export Revit room geometry, false otherwise. Default value is true.
Public propertyExportScope Options which specifies the export scope of Navisworks Exporter. Default value is Model.
Public propertyExportUrls True to export URL parameters, false otherwise. Default value is true.
Public propertyFacetingFactor Faceting factor. Default value is 1.0.
Public propertyFindMissingMaterials True if the file exporter looks for a match for the materials missing from the export, false otherwise. Default value is true.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyParameters Options which specifies the parameter conversion of Navisworks Exporter. Default value is All.
Public propertyViewId The element id of the view to export. InvalidElementId by default. Used only when ExportScope = View.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the NavisworksExportOptions
Public methodGetSelectedElementIds Returns the element ids of the elements to export. Empty by default.
Public methodSetSelectedElementIds Sets the element ids of the elements to export. Used only when ExportScope = SelectedElements.
Top
See Also