InternalDefinitions Class

This object blocks attempts to create new internal definitions as they are not permitted.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBDefinitions
    Autodesk.Revit.DBInternalDefinitions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class InternalDefinitions : Definitions

The InternalDefinitions type exposes the following members.

Properties
 NameDescription
Public propertyIsEmptyIdentifies if the definitions collection is empty.
(Inherited from Definitions)
Public propertyItemRetrieves a definition by a given name.
(Inherited from Definitions)
Public propertySizeThe number of definitions in the collection.
(Inherited from Definitions)
Top
Methods
 NameDescription
Public methodContainsTests for the existence of a definition within the set.
(Inherited from Definitions)
Public methodCreateCreates a new parameter definition using specified options.
(Inherited from Definitions)
Public methodDispose
(Inherited from Definitions)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Protected methodGetBasicIEnumeratorReturns an enumerator that iterates through a collection.
(Inherited from Definitions)
Public methodGetEnumeratorRetrieves an enumerator to the collection.
(Inherited from Definitions)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also