Definitions Class

A base class that supports the addition of new parameter definitions.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class Definitions : IEnumerable<Definition>, 
	IDisposable

The Definitions type exposes the following members.

Constructors
 NameDescription
Public methodDefinitionsConstructs an empty set of parameter definitions.
Top
Properties
 NameDescription
Public propertyIsEmptyIdentifies if the definitions collection is empty.
Public propertyItemRetrieves a definition by a given name.
Public propertySizeThe number of definitions in the collection.
Top
Methods
 NameDescription
Public methodContainsTests for the existence of a definition within the set.
Public methodCreateCreates a new parameter definition using specified options.
Public methodDisposeReleases all resources used by the Definitions
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Protected methodGetBasicIEnumeratorReturns an enumerator that iterates through a collection.
Public methodGetEnumeratorRetrieves an enumerator to the collection.
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks
There are two derivations of this class, one of which handles external parameters and another which handles internal parameters.
See Also