General utility methods in the Autodesk Revit MEP product.
Inheritance Hierarchy Namespace: Autodesk.Revit.DB.PlumbingAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static class PlumbingUtils
Public NotInheritable Class PlumbingUtils
public ref class PlumbingUtils abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type PlumbingUtils = class end
The PlumbingUtils type exposes the following members.
Methods | Name | Description |
---|
  | BreakCurve |
Breaks the pipe curve into two parts at the given position.
|
  | ConnectPipePlaceholdersAtCross(Document, ElementId, ElementId) |
Connects placeholders that looks like Cross connection.
|
  | ConnectPipePlaceholdersAtCross(Document, ElementId, ElementId, ElementId) |
Connects placeholders that looks like Cross connection.
|
  | ConnectPipePlaceholdersAtCross(Document, Connector, Connector, Connector, Connector) |
Connects placeholders that looks like Cross connection.
|
  | ConnectPipePlaceholdersAtElbow(Document, Connector, Connector) |
Connects placeholders that looks like elbow connection.
|
  | ConnectPipePlaceholdersAtElbow(Document, ElementId, ElementId) |
Connects placeholders that looks like elbow connection.
|
  | ConnectPipePlaceholdersAtTee(Document, ElementId, ElementId) |
Connects two placeholders that looks like Tee connection.
|
  | ConnectPipePlaceholdersAtTee(Document, Connector, Connector, Connector) |
Connects three placeholders that looks like Tee connection.
|
  | ConvertPipePlaceholders |
Converts a collection of pipe placeholder elements into pipe elements.
|
  | HasOpenConnector |
Checks if there is open piping connector for the given element - object of pipe curve, pipe fitting or pipe accessory.
|
  | PlaceCapOnOpenEnds |
Places caps on the open connectors of the pipe curve, pipe fitting or pipe accessory.
|
Top
See Also