PlumbingUtilsConnectPipePlaceholdersAtTee(Document, ElementId, ElementId) Method |
Connects two placeholders that looks like Tee connection.
Namespace: Autodesk.Revit.DB.PlumbingAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static bool ConnectPipePlaceholdersAtTee(
Document document,
ElementId placeholder1Id,
ElementId placeholder2Id
)
Public Shared Function ConnectPipePlaceholdersAtTee (
document As Document,
placeholder1Id As ElementId,
placeholder2Id As ElementId
) As Boolean
public:
static bool ConnectPipePlaceholdersAtTee(
Document^ document,
ElementId^ placeholder1Id,
ElementId^ placeholder2Id
)
static member ConnectPipePlaceholdersAtTee :
document : Document *
placeholder1Id : ElementId *
placeholder2Id : ElementId -> bool
Parameters
- document Document
-
The document.
- placeholder1Id ElementId
-
The first element Id of pipe placeholder.
- placeholder2Id ElementId
-
The second element Id of pipe placeholder which connects to first.
Return Value
Boolean
True if connection succeeds, false otherwise.
ExceptionsException | Condition |
---|
ArgumentException |
The element id placeholder1Id is not pipe placeholder.
-or-
The element id placeholder2Id is not pipe placeholder.
-or-
The elements belong to different types of system.
-or-
The curve placeholder2Id does not connect on the curve placeholder1Id or vice versa.
|
ArgumentNullException |
A non-optional argument was null
|
Remarks
The second placeholder must have physically connection with the first one.
If connection fails, the placeholders cannot be physically connected.
See Also