PlumbingUtilsConnectPipePlaceholdersAtCross(Document, ElementId, ElementId, ElementId) Method

Connects placeholders that looks like Cross connection.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static bool ConnectPipePlaceholdersAtCross(
	Document document,
	ElementId placeholder1Id,
	ElementId placeholder2Id,
	ElementId placeholder3Id
)

Parameters

document  Document
The document.
placeholder1Id  ElementId
The first element Id of pipe placeholder.
placeholder2Id  ElementId
The second element Id of pipe placeholder that intersects with first one.
placeholder3Id  ElementId
The third element Id of pipe placeholder that intersects with first one.

Return Value

Boolean
True if connection succeeds, false otherwise.
Exceptions
ExceptionCondition
ArgumentException The element id placeholder1Id is not pipe placeholder. -or- The element id placeholder2Id is not pipe placeholder. -or- The element id placeholder3Id is not pipe placeholder. -or- The elements belong to different types of system. -or- The curve placeholder2Id does not connect on the curve placeholder1Id or vice versa. -or- The curve placeholder3Id does not connect on the curve placeholder1Id or vice versa. -or- The curve placeholder2Id and placeholder3Id are not collinear.
ArgumentNullException A non-optional argument was null
Remarks
If connection fails, the placeholders cannot be physically connected.
See Also