PlumbingUtilsHasOpenConnector Method

Checks if there is open piping connector for the given element - object of pipe curve, pipe fitting or pipe accessory.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static bool HasOpenConnector(
	Document document,
	ElementId elemId
)

Parameters

document  Document
The document.
elemId  ElementId
Element id to check.

Return Value

Boolean
True if given element has open piping connector, false otherwise.
Exceptions
ExceptionCondition
ArgumentNullException A non-optional argument was null
See Also