PlumbingUtilsConnectPipePlaceholdersAtElbow(Document, ElementId, ElementId) Method |
Connects placeholders that looks like elbow connection.
Namespace: Autodesk.Revit.DB.PlumbingAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static bool ConnectPipePlaceholdersAtElbow(
Document document,
ElementId placeholder1Id,
ElementId placeholder2Id
)
Public Shared Function ConnectPipePlaceholdersAtElbow (
document As Document,
placeholder1Id As ElementId,
placeholder2Id As ElementId
) As Boolean
public:
static bool ConnectPipePlaceholdersAtElbow(
Document^ document,
ElementId^ placeholder1Id,
ElementId^ placeholder2Id
)
static member ConnectPipePlaceholdersAtElbow :
document : Document *
placeholder1Id : ElementId *
placeholder2Id : ElementId -> bool
Parameters
- document Document
-
The document.
- placeholder1Id ElementId
-
The element Id of pipe placeholder.
- placeholder2Id ElementId
-
The element Id of pipe placeholder.
Return Value
Boolean
True if connection succeeds, false otherwise.
ExceptionsException | Condition |
---|
ArgumentException |
The element id placeholder1Id is not pipe placeholder.
-or-
The element id placeholder2Id is not pipe placeholder.
-or-
The elements belong to different types of system.
-or-
The curve placeholder1Id and placeholder2Id are not physically connected.
|
ArgumentNullException |
A non-optional argument was null
|
Remarks
There must be a physical end connection of placeholders.
If connection fails, the placeholders cannot be physically connected.
See Also