CreateRelatedFileProgressChangedEventArgs Class

The event arguments used during creating related file phase of [!:Autodesk::Revit::ApplicationServices::Application::WorksharedOperationProgressChanged] in model open operation.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class CreateRelatedFileProgressChangedEventArgs : DataTransferProgressChangedEventArgs

The CreateRelatedFileProgressChangedEventArgs type exposes the following members.

Properties
 NameDescription
Public propertyCancellable Indicates whether an event may be cancelled by an event delegate.
(Inherited from RevitAPIEventArgs)
Public propertyCreatingCloudSharedLocal Indicates if it is creating cloud shared local model.
Public propertyDownloadFinished Indicates if all data downloads are finished.
Public propertyFinishedSize The transferred data size, in bytes, since the last time this event was raised.
(Inherited from DataTransferProgressChangedEventArgs)
Public propertyFullDownload Indicates if download the full data of the document, which will take longer than subsequent downloads.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from RevitAPIEventArgs)
Public propertyLocation Full path of the central model which is to be operated.
(Inherited from WorksharedOperationProgressChangedEventArgs)
Public propertySpeed Speed(bytes/second) in this event.
(Inherited from DataTransferProgressChangedEventArgs)
Public propertyStatus Gets API event status, reflect current operation execution status.
(Inherited from WorksharedOperationProgressChangedEventArgs)
Public propertyTotalSize Total expected data size to transfer, in bytes.
(Inherited from DataTransferProgressChangedEventArgs)
Public propertyTransferMode Data transfer mode in this event.
(Inherited from DataTransferProgressChangedEventArgs)
Top
Methods
 NameDescription
Public methodDispose
(Inherited from RevitAPIEventArgs)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodIsCancelled Indicates whether the event is being cancelled.
(Inherited from RevitAPIEventArgs)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also