DocumentChangedEventArgs Class

The event arguments used by the DocumentChanged event.
Inheritance Hierarchy
SystemObject
  SystemEventArgs
    Autodesk.Revit.DB.EventsRevitAPIEventArgs
      Autodesk.Revit.DB.EventsRevitAPISingleEventArgs
        Autodesk.Revit.DB.EventsDocumentChangedEventArgs

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class DocumentChangedEventArgs : RevitAPISingleEventArgs

The DocumentChangedEventArgs type exposes the following members.

Properties
 NameDescription
Public propertyCancellable Indicates whether an event may be cancelled by an event delegate.
(Inherited from RevitAPIEventArgs)
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from RevitAPIEventArgs)
Public propertyOperation The operation associated with this event
Top
Methods
 NameDescription
Public methodDispose
(Inherited from RevitAPIEventArgs)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetAddedElementIds Returns set of elements newly added to the document.
Public methodGetAddedElementIds(ElementFilter) Returns set of newly added elements that pass the filter.
Public methodGetDeletedElementIds Returns set of elements that were deleted from the document.
Public methodGetDocument Returns document associated with this event
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetModifiedElementIds Returns set of elements that were modified.
Public methodGetModifiedElementIds(ElementFilter) Returns set of elements that were modified according to the given element filter.
Public methodGetTransactionNames Returns names of the transactions associated with this event
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodIsCancelled Indicates whether the event is being cancelled.
(Inherited from RevitAPIEventArgs)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also