BuiltInFailuresEnergyAnalysisFailures Class

Failures about EnergyAnalysis.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBBuiltInFailuresEnergyAnalysisFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class EnergyAnalysisFailures

The BuiltInFailuresEnergyAnalysisFailures type exposes the following members.

Properties
 NameDescription
Public propertyStatic memberComputeRoomVolumeNotCheckedWarn The setting for calculation of Volume Computations is not on. The analysis model produced will be approximate without the computation of Areas and Volumes
Public propertyStatic memberModelWithNoConditionedSpacesWarn The model has no conditioned spaces.
Public propertyStatic memberModelWithNoOccupiedSpacesWarn The model has no occupiable spaces.
Public propertyStatic memberNoRoofsRoomBoundingWarn The energy analysis model does not contain any roof surfaces! If there are roofs in your model, please verify that they are room bounding, and make sure that the room offsets are high enough to include the roofs.
Public propertyStatic memberNoRoofsSpacesBoundingWarn The energy analysis model does not contain any roof surfaces! If there are roofs in your model, please verify that they are space bounding, and make sure that the space offsets are high enough to include the roofs.
Public propertyStatic memberNoRoomBoundingElements Can't create any energy analysis surfaces. There are no Room bounding elements defined in the current phase. Please check the Project Information settings.
Public propertyStatic memberNoRoomBoundingElementsWarn Can't create any energy analysis surfaces. There are no Room bounding elements defined in the current phase. Please check the Project Information settings.
Public propertyStatic memberNoRoomsWarn Revit was unable to identify any rooms. If you are sure that rooms have been created in the project, please check the Project Phase setting to verify that the Project Phase matches the phase in which rooms have been defined in your project.
Public propertyStatic memberNoSpaceBoundingElements Can't create any energy analysis surfaces. There are no Space bounding elements defined in the current phase. Please check the Project Information settings.
Public propertyStatic memberNoSpaceBoundingElementsWarn Can't create any energy analysis surfaces. There are no Space bounding elements defined in the current phase. Please check the Project Information settings.
Public propertyStatic memberNoSpaces Revit was unable to identify any spaces. If you are sure that spaces have been created in the project, please check the Project Phase setting to verify that the Project Phase matches the phase in which spaces have been defined in your project.
Public propertyStatic memberNoSpacesWarn Revit was unable to identify any spaces. If you are sure that spaces have been created in the project, please check the Project Phase setting to verify that the Project Phase matches the phase in which spaces have been defined in your project.
Public propertyStatic memberPlenumWithNoCeilingWarn [Room] has Space Type set to Plenum but has no ceiling surface. A plenum must be separated from the space it serves by a ceiling.
Public propertyStatic memberProblemWithLightingLoadWarn [Room]'s lighting load is too high. This may be caused by an incorrect density value and must be corrected before this space can be included in the load calculations.
Public propertyStatic memberProblemWithPeopleLoadWarn [Room]'s number of people or people load (sensible or latent) is too high. This may be caused by an incorrect density value and must be corrected before this space can be included in the load calculations.
Public propertyStatic memberProblemWithPowerLoadWarn [Room]'s power load is too high. This may be caused by an incorrect density value and must be corrected before this space can be included in the load calculations.
Public propertyStatic memberRoomGeometryCannotFindFreeFacesBoundingElement An error occurred while trying to find the free part of a face of the bounding geometry for [Room] when processing the room-bounding element [Name]. The free part of the face is found by subtracting the portions of the face that overlap various room-bounding element faces.
Public propertyStatic memberRoomGeometryCannotOverlapBoundingElement An error occurred while trying to find the region where a face of the bounding geometry for [Room] overlaps a face of a room-bounding element [Name].
Public propertyStatic memberRoomGeometryCannotTrimBoundingElement An error occurred while trimming the vertical shadow of a room-bounding element [Name] of the bounding geometry for [Room].
Public propertyStatic memberRoomNotPlacedWarn [Family] is not placed. Physical properties such as area will display as "Not Placed" in schedules. You can place the [Family] using the option bar in the [Family] tool, or you can delete the [Family] in a schedule. [Room] will be ignored in the energy analysis model.
Public propertyStatic memberRoomNotUpperBoundedByElement [Family] is not upper bounded by a roof, ceiling or floor element. This can result in incorrect adjacencies and voids in the analytical model. Please ensure that Upper Limit and Limit Offset for [Room] is set correctly.
Public propertyStatic memberRoomVolumeNegativeWarn [Room] has a negative volume? [Room] will be ignored in the energy analysis model.
Public propertyStatic memberRoomVolumeNotComputedWarn [Family] volume can't be computed. The bounding geometry (in 3D) can't be found for [Room]. [Room] will be ignored in the energy analysis model.
Public propertyStatic memberSpaceResolutionOutOfRange Voxel size is out of range.
Public propertyStatic memberSurfaceResolutionOutOfRange Pixel size is out of range.
Public propertyStatic memberUndefinedRooms There are undefined Rooms in the model! Recommend creating a Room schedule and checking the Area parameter of each Room for warnings.
Public propertyStatic memberUndefinedSpaces There are undefined Spaces in the model! Recommend creating a Space schedule and checking the Area parameter of each Space for warnings.
Public propertyStatic memberZoneWithoutSpacesWarn This zone has no spaces.
Top
See Also