BuiltInFailuresRoomFailures Class

Failures about Room.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBBuiltInFailuresRoomFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class RoomFailures

The BuiltInFailuresRoomFailures type exposes the following members.

Properties
 NameDescription
Public propertyStatic memberAreaTagBadViewType Can't Copy Area Tags. The target view doesn't have the same Area Scheme as the original view.
Public propertyStatic memberAreaUnplaceWarning An Area was deleted from all model views but still remains in this project. \n The area can be removed from any schedule or placed back in the model using the Area command.
Public propertyStatic memberCannotMakeRoomsGeometry Could not create geometry for [Room].
Public propertyStatic memberExtensionsOverlapWarning Vertical Extensions on these Walls overlap. This can cause undesirable Joins. Try starting with no overlap and extend the Walls toward one another.
Public propertyStatic memberInvalidReflectivityPercentage The value for Reflectivity must be between 0 and 1.
Public propertyStatic memberInvisibleRoomBoundElemement [Room] Bounding element is invisible in current view.
Public propertyStatic memberLoadareaRecovered The boundary encloses the region for area based load:[Areabasedload].
Public propertyStatic memberOptionConflictBoundariesVaryMainAddToOptionSet Option Conflict between Rooms.\nRoom boundary in the Main Model differs from the apparent boundary in view '[View Name]'.\nTo resolve, select the Main Model Room and use the Add to Design Option Set command.
Public propertyStatic memberOptionConflictBoundariesVaryMainSeparate Option Conflict between Rooms.\nRoom boundary in the Main Model differs from the apparent boundary in view '[View Name]'.\nTo resolve, divide space with Room Separation Lines in the Main Model.
Public propertyStatic memberOptionConflictBoundariesVaryOptionSeparate Option Conflict between Rooms.\nRoom boundary differs from the apparent boundary in view '[View Name]'.\nTo resolve, divide space with Room Separation Lines in the Main Model.
Public propertyStatic memberOptionConflictInLinkBoundariesVaryMainAddToOptionSet Option conflict between rooms in the Revit link '[Link Instance Name]'.\nThe room boundary in the main model of the Revit link differs from the apparent boundary in the linked view '[View Name from Link]'.\nTo resolve the issue, open the Revit link file for editing, select the main model room, and use the Add to Design Option Set tool.
Public propertyStatic memberOptionConflictInLinkBoundariesVaryMainSeparate Option conflict between rooms in the Revit link '[Link Instance Name]'.\nThe room boundary in the main model of the Revit link differs from the apparent boundary in the linked view '[View Name from Link]'.\nTo resolve the issue, open the Revit link file for editing, and use room separation lines to divide the space in the main model.
Public propertyStatic memberOptionConflictInLinkBoundariesVaryOptionSeparate Option conflict between rooms in the Revit link '[Link Instance Name]'.\nThe room boundary differs from the apparent boundary in the linked view '[View Name from Link]'.\nTo resolve the issue, open the Revit link file for editing, and use room separation lines to divide the space in the main model.
Public propertyStatic memberOptionConflictInLinkRoomOverlapMain Option conflict between rooms in the Revit link '[Link Instance Name]'.\nThe room in the Revit link's option '[Option Name in Link]' overlaps a room in the main model.\nTo resolve the issue, open the Revit link file for editing, select the main model room, and use the Add to Design Option Set tool.
Public propertyStatic memberOptionConflictInLinkRoomOverlapOption Option conflict between rooms in the Revit link '[Link Instance Name]'.\nA room in the Revit link's option '[Option #1 Name in Link]' overlaps a room in the Revit link's option '[Option #2 Name in Link]'.\nTo resolve the issue, open the Revit link file for editing, and delete the duplicate room or use room separation lines to divide the space in the main model.
Public propertyStatic memberOptionConflictRoomOverlapMain Option Conflict between Rooms.\nRoom in Option '[Option Name]' overlaps Room in the Main Model.\nTo resolve, select the Main Model Room and use the Add to Design Option Set command.
Public propertyStatic memberOptionConflictRoomOverlapOption Option Conflict between Rooms.\nRoom in Option '[Option Name]' overlaps Room in Option '[Option Name]'.\nTo resolve, delete the duplicate Room or divide space with Room Separation Lines in the Main Model.
Public propertyStatic memberRoomBaseAboveComputationHeight [RoomBase]'s lower offset is above the Computation Height
Public propertyStatic memberRoomBelowCompHeight [Room] Volume is being calculated above the Upper Limit of this [Room]. Change the Upper Limit and Offset or change the height of volume calculations.
Public propertyStatic memberRoomBoundaryMisalignment [Room] bounding element might be misaligned.
Public propertyStatic memberRoomHeightNegative [Room] must have a height greater than 0.
Public propertyStatic memberRoomLevelElevs A [Room]s Upper Limit must be above its Base Level.
Public propertyStatic memberRoomNotEnclosed [Room] is not in a properly enclosed region
Public propertyStatic memberRoomNotEnclosedAreas [Room] is not in a properly enclosed region
Public propertyStatic memberRoomNotEnclosedLoadAreas [Room] is not in a properly enclosed region
Public propertyStatic memberRoomNotEnclosedRooms [Room] is not in a properly enclosed region
Public propertyStatic memberRoomNotEnclosedSpaces [Room] is not in a properly enclosed region
Public propertyStatic memberRoomsCreatedAutomatically [Room] [Room] created automatically.
Public propertyStatic memberRoomsFailed [Room] computations only succeeded without considering the following elements.
Public propertyStatic memberRoomsInSameRegion Multiple [Room] are in the same enclosed region. The correct area and perimeter will be assigned to one [Room] and the others will display "Redundant [Room]." You should separate the regions, delete the extra [Room], or move them into different regions.
Public propertyStatic memberRoomsInSameRegionAreas Multiple [Room] are in the same enclosed region. The correct area and perimeter will be assigned to one [Room] and the others will display "Redundant [Room]." You should separate the regions, delete the extra [Room], or move them into different regions.
Public propertyStatic memberRoomsInSameRegionLoadAreas Multiple [Room] are in the same enclosed region. The correct area and perimeter will be assigned to one [Room] and the others will display "Redundant [Room]." You should separate the regions, delete the extra [Room], or move them into different regions.
Public propertyStatic memberRoomsInSameRegionRooms Multiple [Room] are in the same enclosed region. The correct area and perimeter will be assigned to one [Room] and the others will display "Redundant [Room]." You should separate the regions, delete the extra [Room], or move them into different regions.
Public propertyStatic memberRoomsInSameRegionSpaces Multiple [Room] are in the same enclosed region. The correct area and perimeter will be assigned to one [Room] and the others will display "Redundant [Room]." You should separate the regions, delete the extra [Room], or move them into different regions.
Public propertyStatic memberRoomsOverlapInHeight [Room] volumes overlap. Adjust the Upper Limit and Limit Offset properties of the [rooms].
Public propertyStatic memberRoomsReallyFailed [Room] computations failed. Try to modify the following elements.
Public propertyStatic memberRoomTagBadViewType [Room] Tags can only be placed in Floor Plan, Reflected Ceiling Plan and Section Views.
Public propertyStatic memberRoomTagDeleted A [Room] Tag was deleted, but the corresponding [Room] still exists. You can place another tag for the [Room] using the [Room] Tag tool or select the [Room] and delete it.
Public propertyStatic memberRoomTagNotInRoom [Room] Tag is outside of its [Room]. Enable Leader or move [Room] Tag within its [Room].
Public propertyStatic memberRoomTagNotInRoomToArea [Room] Tag is outside of its [Room]. Enable Leader or move [Room] Tag within its [Room].
Public propertyStatic memberRoomTagNotInRoomToRoom [Room] Tag is outside of its [Room]. Enable Leader or move [Room] Tag within its [Room].
Public propertyStatic memberRoomTagNotInRoomToSpace [Room] Tag is outside of its [Room]. Enable Leader or move [Room] Tag within its [Room].
Public propertyStatic memberRoomTagVolumeNotComputed [Room] Tag is displaying volume that can't be computed.
Public propertyStatic memberRoomTooShort [Room] is very short. If this is not intended, change its Upper Limit and Offset.
Public propertyStatic memberRoomUnplaceWarning A Room was deleted from all model views but still remains in this project. \n The room can be removed from any schedule or placed back in the model using the Room command.
Public propertyStatic memberShowRoomBoundingElements [Room] Bounding elements are highlighted.
Public propertyStatic memberSpaceUnplaceWarning A Space was deleted from all model views but still remains in this project. \n The Space can be removed from any schedule or placed back in the model using the Space command.
Top
See Also