FieldValues Class

Contains values corresponding to domain points. Each domain point may have an array of values, each corresponding to a separate "measurement" for which this value was calculated.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DB.AnalysisFieldValues

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class FieldValues : IDisposable

The FieldValues type exposes the following members.

Constructors
 NameDescription
Public methodFieldValues(FieldValues) Creates a copy of the given FieldValues instance.
Public methodFieldValues(IListValueAtPoint) Creates object from an array of domain point values
Public methodFieldValues(IListVectorAtPoint) Creates object from an array of domain point vectors
Public methodFieldValues(IListValueAtPoint, XYZ) Creates object from an array of domain point values
Top
Properties
 NameDescription
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the FieldValues
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also