FieldValues(IListValueAtPoint, XYZ) Constructor |
Creates object from an array of domain point values
Namespace: Autodesk.Revit.DB.AnalysisAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic FieldValues(
IList<ValueAtPoint> valueAtPoint,
XYZ unitDirection
)
Public Sub New (
valueAtPoint As IList(Of ValueAtPoint),
unitDirection As XYZ
)
public:
FieldValues(
IList<ValueAtPoint^>^ valueAtPoint,
XYZ^ unitDirection
)
new :
valueAtPoint : IList<ValueAtPoint> *
unitDirection : XYZ -> FieldValues
Parameters
- valueAtPoint IListValueAtPoint
-
Array of values, each corresponding to a domain point
- unitDirection XYZ
-
Unit vector that gives the same direction for values (for diagrams)
ExceptionsException | Condition |
---|
ArgumentException |
Members of valueAtPoint contain different numbers of measurements
-or-
unitDirection is not a unit vector
|
ArgumentNullException |
A non-optional argument was null
|
See Also