DetailElementOrderUtils Class

A utility class that arranges the draw order of the detail elements.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBDetailElementOrderUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class DetailElementOrderUtils

The DetailElementOrderUtils type exposes the following members.

Methods
 NameDescription
Public methodStatic memberAreDetailElements Indicates if the elements are all detail elements that participate in detail draw ordering in the view.
Public methodStatic memberBringForward(Document, View, ElementId) Moves the given detail instance one step closer to the front of all other detail instances in the view.
Public methodStatic memberBringForward(Document, View, ICollectionElementId) Moves the given detail instances one step closer to the front of all other detail instances in the view, while keeping the order of the given ones.
Public methodStatic memberBringToFront(Document, View, ElementId) Places the given detail instance in the front of all other detail instances in the view.
Public methodStatic memberBringToFront(Document, View, ICollectionElementId) Places the given detail instances in the front of all other detail instances in the view, while keeping the order of the given ones.
Public methodStatic memberGetDrawOrderForDetails Returns the given detail elements according to the currently specified draw order for the detail elements in a given view.
Public methodStatic memberIsDetailElement Indicates if the element is a detail element that participates in detail draw ordering in the view.
Public methodStatic memberSendBackward(Document, View, ElementId) Moves the given detail instance one step closer to the back of all other detail instances in the view.
Public methodStatic memberSendBackward(Document, View, ICollectionElementId) Moves the given detail instances one step closer to the back with relation to all other detail instances in the view, while keeping the order of the given ones.
Public methodStatic memberSendToBack(Document, View, ElementId) Places the given detail instance behind all detail instances in the view.
Public methodStatic memberSendToBack(Document, View, ICollectionElementId) Places the given detail instances behind all other detail instances in the view, while keeping the order of the given ones.
Top
See Also