DetailElementOrderUtilsSendBackward(Document, View, ICollectionElementId) Method |
Moves the given detail instances one step closer to the back with relation to all other detail
instances in the view, while keeping the order of the given ones.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static void SendBackward(
Document document,
View view,
ICollection<ElementId> detailElementIds
)
Public Shared Sub SendBackward (
document As Document,
view As View,
detailElementIds As ICollection(Of ElementId)
)
public:
static void SendBackward(
Document^ document,
View^ view,
ICollection<ElementId^>^ detailElementIds
)
static member SendBackward :
document : Document *
view : View *
detailElementIds : ICollection<ElementId> -> unit
Parameters
- document Document
-
The document.
- view View
-
The view in which the details appear.
- detailElementIds ICollectionElementId
-
The details to move backward.
ExceptionsException | Condition |
---|
ArgumentException |
The document does not support detail draw order. Only projects and 3d families support draw order. 2d families and in-place families do not support draw order.
-or-
detailElementIds is empty or it contains elements that do not participate in detail draw ordering. Details must be visible in the view.
-or-
In 3d families, detail draw order can only be adjusted in views that are parallel to the document's X, Y or Z axes.
|
ArgumentNullException |
A non-optional argument was null
|
See Also