DetailElementOrderUtilsGetDrawOrderForDetails Method |
Returns the given detail elements according to the currently specified draw order for the detail elements in a given view.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static IList<ElementId> GetDrawOrderForDetails(
View view,
ISet<ElementId> detailIdsToSort
)
Public Shared Function GetDrawOrderForDetails (
view As View,
detailIdsToSort As ISet(Of ElementId)
) As IList(Of ElementId)
public:
static IList<ElementId^>^ GetDrawOrderForDetails(
View^ view,
ISet<ElementId^>^ detailIdsToSort
)
static member GetDrawOrderForDetails :
view : View *
detailIdsToSort : ISet<ElementId> -> IList<ElementId>
Parameters
- view View
-
The view in which the details appear.
- detailIdsToSort ISetElementId
-
The detail to be sorted by draw order.
Return Value
IListElementId
The detail ids sorted from back to front, with earlier elements drawing first and appearing under later elements.
ExceptionsException | Condition |
---|
ArgumentException |
The document does not support detail draw order. Only projects and 3d families support draw order. 2d families and in-place families do not support draw order.
-or-
detailIdsToSort is empty or it contains elements are not visible in the view.
-or-
detailIdsToSort is empty or it contains elements that do not participate in detail draw ordering. Details must be visible in the view.
|
ArgumentNullException |
A non-optional argument was null
|
Remarks
The sort order is from back to front, with earlier elements drawing first and appearing under later elements.
See Also