DockablePane Class

A user interface pane that participates in Revit's docking window system.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.UIDockablePane

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class DockablePane : IDisposable

The DockablePane type exposes the following members.

Constructors
 NameDescription
Public methodDockablePane(DockablePane) Constructs a new copy of the input DockablePane object.
Public methodDockablePane(DockablePaneId) Gets the pane with identifier %id%.
Top
Properties
 NameDescription
Public propertyId The unique identifier for this dockable pane.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the DockablePane
Public methodGetTitle Returns the current title (a.k.a. window caption) of the dockable pane.
Public methodHide If the pane is on screen, hide it. Has no effect on built-in Revit dockable panes.
Public methodIsShown Identify the pane is currently visible or in a tab.
Public methodStatic memberPaneExists Returns true if %id% refers to a dockable pane window that currently exists in the Revit user interface, whether it's hidden or shown.
Public methodStatic memberPaneIsBuiltIn Returns true if %id% refers to a built-in Revit dockable pane, rather than one created by an add-in.
Public methodStatic memberPaneIsRegistered Returns true if %id% refers to a built-in Revit dockable pane, or an add-in pane that has been properly registered with %Autodesk.Revit.UI.UIApplication.RegisterDockablePane%.
Public methodShow If the pane is not currently visible or in a tab, display the pane in the Revit user interface at its last docked location.
Top
See Also