ImporterIFCUtilsCreateEmptyFamily Method |
Creates an empty family of a given category.
Namespace: Autodesk.Revit.DB.IFCAssembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static ElementId CreateEmptyFamily(
ImporterIFC importerIFC,
Document aDoc,
ElementId catId,
string familyName
)
Public Shared Function CreateEmptyFamily (
importerIFC As ImporterIFC,
aDoc As Document,
catId As ElementId,
familyName As String
) As ElementId
public:
static ElementId^ CreateEmptyFamily(
ImporterIFC^ importerIFC,
Document^ aDoc,
ElementId^ catId,
String^ familyName
)
static member CreateEmptyFamily :
importerIFC : ImporterIFC *
aDoc : Document *
catId : ElementId *
familyName : string -> ElementId
Parameters
- importerIFC ImporterIFC
-
The importer.
- aDoc Document
-
The document to create the family.
- catId ElementId
-
The category id.
- familyName String
-
The family name.
Return Value
ElementId
The created family id.
Exceptions
See Also