CurveArray Class

An array that can contain curves.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBAPIObject
    Autodesk.Revit.DBCurveArray

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class CurveArray : APIObject, IEnumerable

The CurveArray type exposes the following members.

Constructors
 NameDescription
Public methodCurveArrayInitializes a new instance of the CurveArray class
Top
Properties
 NameDescription
Public propertyIsEmptyTest to see if the array is empty.
Public propertyItemGets or sets a curve at a specified index within the array.
Public propertySizeReturns the number of curves that are in the array.
Top
Methods
 NameDescription
Public methodAppendAdd the curve to the end of the array.
Public methodClearRemoves every curve from the array, rendering it empty.
Public methodForwardIteratorRetrieve a forward moving iterator to the array.
Public methodGetEnumeratorRetrieve a forward moving iterator to the array.
Public methodInsertInsert the specified curve into the array.
Public methodReverseIteratorRetrieve a backward moving iterator to the array.
Top
See Also