CurveArray Class

An array that can contain curves.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBAPIObject
    Autodesk.Revit.DBCurveArray

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class CurveArray : APIObject, IEnumerable

The CurveArray type exposes the following members.

Constructors
 NameDescription
Public methodCurveArrayInitializes a new instance of the CurveArray class
Top
Properties
 NameDescription
Public propertyIsEmptyTest to see if the array is empty.
Public propertyCode exampleIsReadOnlyIdentifies if the object is read-only or modifiable.
(Inherited from APIObject)
Public propertyItemGets or sets a curve at a specified index within the array.
Public propertySizeReturns the number of curves that are in the array.
Top
Methods
 NameDescription
Public methodAppendAdd the curve to the end of the array.
Public methodClearRemoves every curve from the array, rendering it empty.
Public methodDisposeCauses the object to release immediately any resources it may be utilizing.
(Inherited from APIObject)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodForwardIteratorRetrieve a forward moving iterator to the array.
Public methodGetEnumeratorRetrieve a forward moving iterator to the array.
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodInsertInsert the specified curve into the array.
Public methodReverseIteratorRetrieve a backward moving iterator to the array.
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also