ExporterIFCUtilsCanExportWallGeometryAsExtrusion Method |
Identifies if the base geometry of the wall can be represented as an extrusion.
Namespace: Autodesk.Revit.DB.IFCAssembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static bool CanExportWallGeometryAsExtrusion(
Element element,
IFCRange range,
Curve curve
)
Public Shared Function CanExportWallGeometryAsExtrusion (
element As Element,
range As IFCRange,
curve As Curve
) As Boolean
public:
static bool CanExportWallGeometryAsExtrusion(
Element^ element,
IFCRange^ range,
Curve^ curve
)
static member CanExportWallGeometryAsExtrusion :
element : Element *
range : IFCRange *
curve : Curve -> bool
Parameters
- element Element
-
The wall or in-place wall element.
- range IFCRange
-
The range. This consists of two double values representing the height in Z at the start and the end
of the range. If the values are identical the entire wall is used.
- curve Curve
-
The wall's base curve.
Return Value
Boolean
True if the wall export can be made in the form of an extrusion, false if the
geometry cannot be assigned to an extrusion.
Exceptions
See Also