PanelTypeSet Class

A set that contains panel types.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBAPIObject
    Autodesk.Revit.DBPanelTypeSet

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class PanelTypeSet : APIObject, 
	IEnumerable

The PanelTypeSet type exposes the following members.

Constructors
 NameDescription
Public methodPanelTypeSetInitializes a new instance of the PanelTypeSet class
Top
Properties
 NameDescription
Public propertyIsEmptyTest to see if the set is empty.
Public propertySizeReturns the number of panel types that are in the set.
Top
Methods
 NameDescription
Public methodClearRemoves every panel type from the set, rendering it empty.
Public methodContainsTests for the existence of a panel type within the set.
Public methodEraseRemoves a specified panel type from the set.
Public methodForwardIteratorRetrieve a forward moving iterator to the set.
Public methodGetEnumeratorRetrieve a forward moving iterator to the set.
Public methodInsertInsert the specified panel type into the set.
Public methodReverseIteratorRetrieve a backward moving iterator to the set.
Top
See Also