EditorInteraction Class

Wraps the EditorInteractionType for the Pane to allow for clients to override their type dynamically if need be.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.UIEditorInteraction

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class EditorInteraction

The EditorInteraction type exposes the following members.

Constructors
 NameDescription
Public methodEditorInteraction Construct a default interaction.
Public methodEditorInteraction(EditorInteractionType) Construct the interaction with the specified type.
Top
Properties
 NameDescription
Public propertyInteractionType The type of interaction.
Top
Methods
 NameDescription
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also