EditorInteractionInteractionType Property |
The type of interaction.
Namespace: Autodesk.Revit.UIAssembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic virtual EditorInteractionType InteractionType { get; set; }
Public Overridable Property InteractionType As EditorInteractionType
Get
Set
public:
virtual property EditorInteractionType InteractionType {
EditorInteractionType get ();
void set (EditorInteractionType value);
}
abstract InteractionType : EditorInteractionType with get, set
override InteractionType : EditorInteractionType with get, set
Property Value
EditorInteractionType
Remarks
This property is overridable to allow for clients to
dynamically return the type. For example, if your pane
interacts with certain editors or has different "modes"
based on user workflow.
See Also