RevitCommandId Class

Represents a command id in Autodesk Revit.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.UIRevitCommandId

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class RevitCommandId : IDisposable

The RevitCommandId type exposes the following members.

Properties
 NameDescription
Public propertyCanHaveBinding Indicates whether the command can be assigned a binding to an external add-in.
Public propertyHasBinding Indicates whether a replacement of either the Execute or CanExecute events (or both) have been applied to this command.
Public propertyId The command id.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyName The command name.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the RevitCommandId
Public methodStatic memberLookupCommandId Looks up and retrieves the Revit command id with the given id string.
Public methodStatic memberLookupPostableCommandId Looks up and retrieves the Revit command id with the given id string.
Top
Remarks
Each Revit command is assigned a command id and non-localized name. This class allows you to look up a command by its name, and represents any Revit command in the use of an AddInCommandBinding.
See Also