TabbedDialogExtension Class

Contains the information required to create and implement the behavior for the new tab inside the Revit options dialog.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.UITabbedDialogExtension

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class TabbedDialogExtension

The TabbedDialogExtension type exposes the following members.

Constructors
 NameDescription
Public methodTabbedDialogExtensionConstructs a extension instance with a control and ok action handler.
Top
Properties
 NameDescription
Public propertyControlThe control.
Public propertyOnCancelActionThe cancel handler.
Public propertyOnOKActionThe ok handler.
Public propertyOnRestoreDefaultsActionThe restore defaults handler.
Top
Methods
 NameDescription
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetContextualHelpGets the contextual help.
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodSetContextualHelpSets the contextual help.
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks
Each page has an associated user interface control and the handlers of buttons Cancel, Restore Defaults and help can optionally be set. The size of the control is limited to 305 (height) x 288 (width) in physical pixels.
See Also