Checks whether this combination of fallback and target parameters
can be used as a valid combination of inputs.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2015
Syntax
C# |
---|
public bool AreTargetAndFallbackCompatible( TessellatedShapeBuilderTarget target, TessellatedShapeBuilderFallback fallback ) |
Visual Basic |
---|
Public Function AreTargetAndFallbackCompatible ( _ target As TessellatedShapeBuilderTarget, _ fallback As TessellatedShapeBuilderFallback _ ) As Boolean |
Visual C++ |
---|
public: bool AreTargetAndFallbackCompatible( TessellatedShapeBuilderTarget target, TessellatedShapeBuilderFallback fallback ) |
Parameters
- target
- Type: Autodesk.Revit.DB..::..TessellatedShapeBuilderTarget
What kind of geometrical objects should be built.
- fallback
- Type: Autodesk.Revit.DB..::..TessellatedShapeBuilderFallback
What should be done if a geometrical object described by 'target' parameter cannot be built using all data from all stored face sets.
Return Value
True if the combination of fallback and target are a valid combination, false otherwise.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |