Describes what TessellatedShapeBuilder function
should do, if it cannot build a requested TessellatedShapeBuilderTarget.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2015
Syntax
C# |
---|
public enum TessellatedShapeBuilderFallback |
Visual Basic |
---|
Public Enumeration TessellatedShapeBuilderFallback |
Visual C++ |
---|
public enum class TessellatedShapeBuilderFallback |
Members
Member name | Description |
---|---|
Abort | Do nothing. |
Salvage | Ignore invalid data, and use all valid data. Note that if a complete set of data describes a solid and some data are ignored, then the result will be a sheet and not a solid. |
Mesh | If a requested geometrical object cannot be built using all data from the face set(s), create a mesh while using as much data from the face set(s) as possible. |