Describes what TessellatedShapeBuilder
should generate, if possible.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2015
Syntax
C# |
---|
public enum TessellatedShapeBuilderTarget |
Visual Basic |
---|
Public Enumeration TessellatedShapeBuilderTarget |
Visual C++ |
---|
public enum class TessellatedShapeBuilderTarget |
Members
Member name | Description |
---|---|
Solid | A solid, i.e., a Geometry, where all edges are shared by two and only two faces and which divides all 3d space into bounded inner and infinite outer area(s). |
AnyGeometry | A Geometry, which depending on input data can be a Solid or a 'sheet', where there is no fully enclosed volume formed by the generated faces. |
Mesh | A mesh. |