TessellatedShapeBuilderAreTargetAndFallbackCompatible Method |
Checks whether this combination of fallback and target parameters
can be used as a valid combination of inputs.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool AreTargetAndFallbackCompatible(
TessellatedShapeBuilderTarget target,
TessellatedShapeBuilderFallback fallback
)
Public Function AreTargetAndFallbackCompatible (
target As TessellatedShapeBuilderTarget,
fallback As TessellatedShapeBuilderFallback
) As Boolean
public:
bool AreTargetAndFallbackCompatible(
TessellatedShapeBuilderTarget target,
TessellatedShapeBuilderFallback fallback
)
member AreTargetAndFallbackCompatible :
target : TessellatedShapeBuilderTarget *
fallback : TessellatedShapeBuilderFallback -> bool
Parameters
- target TessellatedShapeBuilderTarget
-
What kind of geometrical objects should be built.
- fallback TessellatedShapeBuilderFallback
-
What should be done if a geometrical object described by 'target'
parameter cannot be built using all data from all stored face sets.
Return Value
Boolean
True if the combination of fallback and target are a valid combination, false
otherwise.
Exceptions
See Also