Maps a portion of the index buffer into memory, so that indices can be written into it.
see
IndexStream.
Namespace: Autodesk.Revit.DB.DirectContext3DAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2017
Syntax
C# |
---|
public void Map(
int sizeInShortInts
) |
Visual Basic |
---|
Public Sub Map ( _
sizeInShortInts As Integer _
) |
Visual C++ |
---|
public:
void Map(
int sizeInShortInts
) |
Parameters
- sizeInShortInts
- Type: System..::..Int32
The size of the part of the buffer to be mapped, measured in short integers.
Must be less than or equal to the size of the IndexBuffer
Exceptions
Exception | Condition |
---|
Autodesk.Revit.Exceptions..::..InvalidOperationException |
This IndexBuffer is not available because Revit is not currently rendering. In general, this IndexBuffer must be used in the scope of the RenderScene() callback of IDirectContext3DServer.
-or-
Thrown if the buffer is smaller than sizeInShortInts.
|
See Also