IndexBufferMap Method

Maps a portion of the index buffer into memory, so that indices can be written into it. see IndexStream.

Namespace: Autodesk.Revit.DB.DirectContext3D
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void Map(
	int sizeInShortInts
)

Parameters

sizeInShortInts  Int32
The size of the part of the buffer to be mapped, measured in short integers. Must be less than or equal to the size of the IndexBuffer
Exceptions
ExceptionCondition
InvalidOperationException This IndexBuffer is not available because Revit is not currently rendering. In general, this IndexBuffer must be used in the scope of the RenderScene() callback of IDirectContext3DServer. -or- Thrown if the buffer is smaller than sizeInShortInts.
See Also