Identifies if the given command can be posted, using PostCommand(RevitCommandId).
Namespace: Autodesk.Revit.UIAssembly: RevitAPIUI (in RevitAPIUI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public bool CanPostCommand( RevitCommandId commandId ) |
Visual Basic |
---|
Public Function CanPostCommand ( _ commandId As RevitCommandId _ ) As Boolean |
Visual C++ |
---|
public: bool CanPostCommand( RevitCommandId^ commandId ) |
Parameters
- commandId
- Type: Autodesk.Revit.UI..::..RevitCommandId
The command Id.
Remarks
Only members of Autodesk.Revit.UI.PostableCommand or external commands can be posted.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when commandId is nullNothingnullptra null reference (Nothing in Visual Basic). |