Represents an active session of the Autodesk Revit user interface, providing access to
UI customization methods, events, the main window, and the active document.
Namespace: Autodesk.Revit.UIAssembly: RevitAPIUI (in RevitAPIUI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public class UIApplication : IDisposable |
Visual Basic |
---|
Public Class UIApplication _ Implements IDisposable |
Visual C++ |
---|
public ref class UIApplication : IDisposable |
Remarks
You can access documents from the database level Application object, obtained from
the Application property. If you have an instance of the database level Application object,
you can construct a UIApplication instance from it.
Inheritance Hierarchy
System..::..Object
Autodesk.Revit.UI..::..UIApplication
Autodesk.Revit.UI.Macros..::..ApplicationEntryPoint
Autodesk.Revit.UI..::..UIApplication
Autodesk.Revit.UI.Macros..::..ApplicationEntryPoint