Posts the command to the Revit message queue to be invoked when control returns from the current API context.
Namespace: Autodesk.Revit.UIAssembly: RevitAPIUI (in RevitAPIUI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public void PostCommand( RevitCommandId commandId ) |
Visual Basic |
---|
Public Sub PostCommand ( _ commandId As RevitCommandId _ ) |
Visual C++ |
---|
public: void PostCommand( RevitCommandId^ commandId ) |
Parameters
- commandId
- Type: Autodesk.Revit.UI..::..RevitCommandId
The command Id.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when commandId is nullNothingnullptra null reference (Nothing in Visual Basic). |
Autodesk.Revit.Exceptions..::..ArgumentException | If the command cannot be posted. |
Autodesk.Revit.Exceptions..::..InvalidOperationException | If there is a command already been posted. |