Creates an empty family of a given category.
Namespace: Autodesk.Revit.DB.IFCAssembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public static ElementId CreateEmptyFamily( ImporterIFC importerIFC, Document aDoc, ElementId catId, string familyName ) |
Visual Basic |
---|
Public Shared Function CreateEmptyFamily ( _ importerIFC As ImporterIFC, _ aDoc As Document, _ catId As ElementId, _ familyName As String _ ) As ElementId |
Visual C++ |
---|
public: static ElementId^ CreateEmptyFamily( ImporterIFC^ importerIFC, Document^ aDoc, ElementId^ catId, String^ familyName ) |
Parameters
- importerIFC
- Type: Autodesk.Revit.DB.IFC..::..ImporterIFC
The importer.
- aDoc
- Type: Autodesk.Revit.DB..::..Document
The document to create the family.
- catId
- Type: Autodesk.Revit.DB..::..ElementId
The category id.
- familyName
- Type: System..::..String
The family name.
Return Value
The created family id.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |