The main class provided by Revit to allow implementation of IFC import.
Namespace: Autodesk.Revit.DB.IFCAssembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public class ImporterIFC : IDisposable |
Visual Basic |
---|
Public Class ImporterIFC _ Implements IDisposable |
Visual C++ |
---|
public ref class ImporterIFC : IDisposable |
Remarks
An instance of this class is provided to clients which implement IImporterIFC
in order to provide an implementation for IFC import. It contains information
on the options selected by the user for the import operation, as well as
members used to access specific types of data needed to implement the import
properly.
Inheritance Hierarchy
System..::..Object
Autodesk.Revit.DB.IFC..::..ImporterIFC
Autodesk.Revit.DB.IFC..::..ImporterIFC